兼容华为ExaGear的银河麒麟v10 sp1 arm64内核(飞腾网卡不可用)

@Ta 2021-12-20发布,2022-03-01修改 11023点击

已知问题:

  • 可能会无法开机,后果自负。如果真的不能开机,请看“使用方法”里的大字。
  • 我们不清楚它与华为麒麟CPU的兼容性情况,但是有用户尝试安装并且由于/boot分区为只读而失败。如果你出现这种情况,请看卸载说明。
  • 有用户表示它与华为鲲鹏系列CPU兼容。
  • 它与飞腾CPU兼容,但是切换到该内核后,飞腾自带网卡不可用,只能使用USB网卡。
  • 不支持kysec(银河麒麟的自带安全机制,类似SeLinux)。
  • 受到kysec的影响,安装linux-headers-5.4.18-arm64.deb非常慢,需要十分钟。

安装方法

依次安装以下软件包。注意受kysec影响,安装第一个软件包非常慢,需要十分钟。

有风险,可能会无法开机,后果自负。如果真的不能开机,请看“使用方法”里的大字。

尝试之前建议先安装其他版本内核备用,或者创建系统备份。

如果安装失败导致apt陷入不可用状态,请看卸载说明。

linux-headers-5.4.18-arm64.deb(10.6 MB)

linux-modules-5.4.18-arm64.deb(44.3 MB)

linux-image-5.4.18-arm64.deb(7.96 MB)

使用方法

重启电脑,在出现启动菜单时选择“Advanced options for Kylin V10 SP1”(注意不是“Advanced options for Kylin V10”,有时候两者会同时存在),然后选择“Kylin V10 SP1, with 5.4.18”。

如果不能开机,请使用上面的方法,但是选择另一个版本的内核。

进入系统后可能会没网,我解决不了网卡驱动问题,只能使用USB网卡。

如果不想再使用该内核,启动时选择其他内核版本即可。

卸载说明

  1. 先尝试全部卸载
sudo apt purge linux-image-5.4.18 linux-modules-5.4.18 linux-headers-5.4.18
  1. 如果不成功,再尝试逐个卸载
sudo apt purge linux-headers-5.4.18
sudo apt purge linux-modules-5.4.18
sudo apt purge linux-image-5.4.18
  1. 如果还是不成功,先把/boot分区挂载为可写,然后再卸载
sudo mount -o remount,rw /boot
sudo apt purge linux-headers-5.4.18
sudo apt purge linux-modules-5.4.18
sudo apt purge linux-image-5.4.18
回复列表(5|隐藏机器人聊天)
添加新回复
回复需要登录